Can't log in to the player

I can’t log into the player - but i can log into the profile and forum sections fine. (BTW it is pretty confusing having three separate logins for essentially one site)

The login page giving me problems is this one: Resonate

it will only accept my email address , not my username

when I attempt to log in it says “La patience est une vertu…”

then after a bit says “If you just signed up or changed your password, please try again in a few seconds…”

nothing I do will get me past that point.

my password is quite long, but is purely alphanumeric characters, I’m using the same password on the other sections of the site without problems.

I’m using firefox on linux mint.

any suggestions? is there a known issue?

Welcome, @blackthorn!

Agreed. We’re moving soon to a new infrastructure where we won’t have multiple logins. Looking forward to it.

Did you accept cookies on the Player? The cookies are strictly to run the Player itself; there is no other tracking involved.

1 Like

Ok this is strange but I just logged in successfully - did something change?

BTW thanks for moving this post and sorry I posted in the wrong place initially I’m still finding my way around.

Yes I have been accepting cookies.

1 Like

I had earlier changed my password for a shorter one in the player only - is there a character limit that could have been causing the problem? Even so I still wasn’t able to log in until just now.

Password length shouldn’t be an issue unless it were like 70 chars or something. We’re doing regular updates during our migration to our new infrastructure, so it is possible something just got updated or synced while you were waiting.

I had had this problem for some time, over a week. So if there were updates today that might have fixed it but couldn’t have caused it. I will check how it goes over the next few days and report back here if it re-occurs.

2 Likes

Thank you, @blackthorn

Hi,

I have recently signed up for a listener account and am facing the same problem.
I’ve waited more than a few seconds so I don’t think that’s it :slight_smile:
I had previously declined cookies, then accepted them but no change.
The account was created on https://resonate.is and i can sign in fine there.

Details:
The POST request to https://stream.resonate.coop/api/v1/oauth2/password with

{
  "username": "user@example.net",
  "password": "xxxx"
}

returns a 400 Bad Request response with

{
  "message": "Unauthorized",
  "status": 400
}

Ok this is

I did have “unusual” characters in my password and changing it to use only [A-Za-z0-6] worked.

1 Like

I tried resetting my password to only alphanumeric as well. It kind of solved the initial problem, i.e. I am forwarded to the player. However it doesn’t look like I am logged in there, it still says “Log in to listen to full song” at the bottom of the screen.